TV Browser Mini läuft leider nicht unter 3.0 (SVN)

Hier haben Plugin-Entwickler die Möglichkeit, sich auszutauschen.
Benutzeravatar
Siggi
Moderator
Beiträge: 2065
Registriert: 31 Dez 2003, 12:21
Wohnort: Doberlug - Kirchhain

TV Browser Mini läuft leider nicht unter 3.0 (SVN)

Beitragvon Siggi » 09 Aug 2009, 13:12

Hallo an die Entwickler.

Das Plugin TV-Browser Mini von Bennedikt Grabenmaier läuft leider nicht mehr unter TV-Browser 3.0 SVN Build 08.08.09.

Es wird folgender Fehler bei dem Datenexport ausgegeben:

Exception in thread "Thread-10" java.lang.NoSuchMethodError: devplugin.Date.getDaysSince1970()I
at tvbrowsermini.TVBrowserMini.exportFile(TVBrowserMini.java:540)
at tvbrowsermini.TVBrowserMini.export(TVBrowserMini.java:469)
at tvbrowsermini.TVBrowserMini.access$7(TVBrowserMini.java:374)
at tvbrowsermini.TVBrowserMini$1$1.run(TVBrowserMini.java:156)

Das Quellen sollten im SVN liegen.

Danke im Voraus.
mfg Siggi

PS: Wer Fehler findet, darf Sie behalten!!! :-)

ds10
Site Admin
Beiträge: 16196
Registriert: 23 Jun 2005, 12:36
Kontaktdaten:

Re: TV Browser Mini läuft leider nicht unter 3.0 (SVN)

Beitragvon ds10 » 09 Aug 2009, 13:31

Die benutze Methode war deprecated und wurde deshalb in 3.0 entfernt. Sollte eigentlich kein so großes Problem sein.
"First they ignore you, then they ridicule you, then they fight you, then you win." - Mahatma Gandhi
Unterstütze die Weiterentwicklung von TV-Browser

ds10
Site Admin
Beiträge: 16196
Registriert: 23 Jun 2005, 12:36
Kontaktdaten:

Re: TV Browser Mini läuft leider nicht unter 3.0 (SVN)

Beitragvon ds10 » 09 Aug 2009, 14:32

http://www.tvbrowser.org/downloads/test/TVBrowserMini.jar

Das kannst du dann übrigens ganz einfach per DragAndDrop in die Programmtabelle installieren.
"First they ignore you, then they ridicule you, then they fight you, then you win." - Mahatma Gandhi
Unterstütze die Weiterentwicklung von TV-Browser

Benutzeravatar
Siggi
Moderator
Beiträge: 2065
Registriert: 31 Dez 2003, 12:21
Wohnort: Doberlug - Kirchhain

Re: TV Browser Mini läuft leider nicht unter 3.0 (SVN)

Beitragvon Siggi » 09 Aug 2009, 15:26

Hi,

wenn ich diese Datei in die Programmtabelle ziehe meldet TV-Browser "Die folgenden Plugins sind bereits in einer aktuellen Version installiert."

Er nimmt die Datei nicht an, da wohl die Versionsnummer gleich oder kleiner ist.
Sollte man das ändern, sodass man gleiche oder ältere Versionsstände reinziehen kann?

Danke.
mfg Siggi



PS: Wer Fehler findet, darf Sie behalten!!! :-)

Benutzeravatar
Siggi
Moderator
Beiträge: 2065
Registriert: 31 Dez 2003, 12:21
Wohnort: Doberlug - Kirchhain

Re: TV Browser Mini läuft leider nicht unter 3.0 (SVN)

Beitragvon Siggi » 09 Aug 2009, 15:43

Hi ds10,

ja der Exportfehler ist behoben. Nur werden leider auf dem PDA keine Daten angezeigt. Die Sender sind zwar da, aber es fehlen die Senderdaten. Beim Start auf dem PDA meldet er "ACHTUNG Keine TV-Daten".

Danke im Voraus.
mfg Siggi



PS: Wer Fehler findet, darf Sie behalten!!! :-)

ds10
Site Admin
Beiträge: 16196
Registriert: 23 Jun 2005, 12:36
Kontaktdaten:

Re: TV Browser Mini läuft leider nicht unter 3.0 (SVN)

Beitragvon ds10 » 09 Aug 2009, 15:48

Tja, keine Ahnung ich habe keinen PDA, daher kann ich da auch nicht helfen.
"First they ignore you, then they ridicule you, then they fight you, then you win." - Mahatma Gandhi
Unterstütze die Weiterentwicklung von TV-Browser

ds10
Site Admin
Beiträge: 16196
Registriert: 23 Jun 2005, 12:36
Kontaktdaten:

Re: TV Browser Mini läuft leider nicht unter 3.0 (SVN)

Beitragvon ds10 » 09 Aug 2009, 22:54

Ich hab' jetzt doch nochmal etwas geändert, funktioniert es jetzt?
"First they ignore you, then they ridicule you, then they fight you, then you win." - Mahatma Gandhi
Unterstütze die Weiterentwicklung von TV-Browser

Benutzeravatar
Siggi
Moderator
Beiträge: 2065
Registriert: 31 Dez 2003, 12:21
Wohnort: Doberlug - Kirchhain

Re: TV Browser Mini läuft leider nicht unter 3.0 (SVN)

Beitragvon Siggi » 10 Aug 2009, 18:42

Hi ds10,

der PDA meldet immer noch, dass keine Daten da sind. Muss das Datumsformat auch vom Applet angepasst werden? Oder kannst du das Export file so erzeugen lassen, dass es dem alten Stand entspricht?

Ich hoffe Bennedikt meldet sich. Ich hatte ihn schon im ICQ angeschrieben. Wär schade, wenn das Plugin stirbt. Dann bekomm ich keine TV-Daten mehr auf meinen PDA.

Bis dann.
mfg Siggi



PS: Wer Fehler findet, darf Sie behalten!!! :-)

benne
Plugin-Developer
Beiträge: 247
Registriert: 28 Feb 2007, 09:27
Wohnort: Bonn
Kontaktdaten:

Re: TV Browser Mini läuft leider nicht unter 3.0 (SVN)

Beitragvon benne » 10 Aug 2009, 22:13

sorry, dass ich mir so rar gemacht habe. Aber auch ich habe keinen PDA mehr und z.Z. auch kein Visual Studio mehr. Nen Java Fehler könnte ich fixen aber aber am PDA Programm kann ich gerade wirklich nichts ändern.

Benutzeravatar
Siggi
Moderator
Beiträge: 2065
Registriert: 31 Dez 2003, 12:21
Wohnort: Doberlug - Kirchhain

Re: TV Browser Mini läuft leider nicht unter 3.0 (SVN)

Beitragvon Siggi » 12 Aug 2009, 19:34

Hi benne und co.

könntest du trotzdem dran bleiben und bei Gelegenheit das Problem fixen.

Weißt du, was das Problem sein könnte? Dann kann auch evtl. jemand anderes mal schauen.

Bis dann.
mfg Siggi



PS: Wer Fehler findet, darf Sie behalten!!! :-)

benne
Plugin-Developer
Beiträge: 247
Registriert: 28 Feb 2007, 09:27
Wohnort: Bonn
Kontaktdaten:

Re: TV Browser Mini läuft leider nicht unter 3.0 (SVN)

Beitragvon benne » 13 Mär 2010, 20:48

so versuch mal

bilbo_b
Junior Member
Beiträge: 17
Registriert: 28 Sep 2007, 06:54

Re: TV Browser Mini läuft leider nicht unter 3.0 (SVN)

Beitragvon bilbo_b » 03 Mai 2010, 08:45

Das Plugin funktioniert zwar und exportiert die Daten. Allerdings ist die Performance der PPC Version dann absolut im Keller. Das erste Ladend er Datei mit der aktuellen Übersicht dauert spürbar länger. Wenn ich dann auf den Menüpunkt "Primetime anzeigen" gehe (oder soähnlich, steht der komplette PDA für fast 2 Minuten ohne Reaktion. Danach zeigt er die Zeiten, ich kann aber erst nach weiteren 20 Sekunden scrollen...

Fehlen da in der Datenbank eventuell die Indizes? Wenn ja, wo müssen die gesetzt werden?

Achso: ich verwende einen XDA Diamond (1) mit Windows Mobil 6.1, Original O2 ROM. Eine alte DB war im Vergleich um etliches schneller auf dem PDA. Aber der Export selber hat länger gedauert. Der ist mit dem neuen Plugin schneller.

Benutzeravatar
Siggi
Moderator
Beiträge: 2065
Registriert: 31 Dez 2003, 12:21
Wohnort: Doberlug - Kirchhain

Re: TV Browser Mini läuft leider nicht unter 3.0 (SVN)

Beitragvon Siggi » 03 Mai 2010, 12:41

Die PDA Anwendung wird nicht mehr weiterentwickelt.

Das war die Aussage des Programmierers.
mfg Siggi



PS: Wer Fehler findet, darf Sie behalten!!! :-)

bilbo_b
Junior Member
Beiträge: 17
Registriert: 28 Sep 2007, 06:54

Re: TV Browser Mini läuft leider nicht unter 3.0 (SVN)

Beitragvon bilbo_b » 03 Mai 2010, 13:43

Schade. Mir gehts aber weniger um die Anwendung auf dem PDA, als vielmehr um den Export auf dem PC... Ich hab leider keinen Plan von Java, kann da also nichts dran fixen. Die PDA Anwendung kann ich zur Not neu basteln, da ich mit der PRogrammierung von Windows Mobile und SQLite doch ein wneig Erfahrung habe... aber mit Java hab ich mich noch nie beschäftigt :-(

bilbo_b
Junior Member
Beiträge: 17
Registriert: 28 Sep 2007, 06:54

Re: TV Browser Mini läuft leider nicht unter 3.0 (SVN)

Beitragvon bilbo_b » 03 Mai 2010, 17:08

Ich bins wieder... irgendwie scheine ich die falsche Version geladen zu haben. Ich hatte die Version weiter aus diesem Fred hier geladen und damit gab es die Probleme. Das ist mir aufgefallen, als ich heute den Export beider Versionen vergleichen wollte. Die Version in der 2.7.5 meldete Export Plugin Version 0.5.5.0 und die aus diesem Fred 0.5.3.0, Mit der höheren Versionsnummer ist auch der Export der aus der aktuellen 3.0 beta2 Version wieder in annehmbarer Zeit darstellbar. Sorry. Also an alle, welche in die gleiche Falle tappen: die aktuelle Version ist 0.5.5.0 aus diesem Fred.

Ich hatte mich schon moralisch darauf eingestellt nun Java lernen zu müssen um eine eigene Version zu bauen. Das kann ich mir nur sparen.


Zurück zu „Plugin-Entwickler“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste