could not store settings for programminfo .....

Antwort erstellen


Diese Frage dient dazu, das automatisierte Versenden von Formularen durch Spam-Bots zu verhindern.

BBCode ist eingeschaltet
[img] ist eingeschaltet
[flash] ist ausgeschaltet
[url] ist eingeschaltet
Smilies sind ausgeschaltet

Die letzten Beiträge des Themas

Ich habe die Datenschutzerklärung gelesen und bin damit einverstanden.

   

Ansicht erweitern Die letzten Beiträge des Themas: could not store settings for programminfo .....

Re: could not store settings for programminfo .....

von renzorosso » 12 Feb 2017, 03:55

Danke, hat bestens funktioniert!

Re: could not store settings for programminfo .....

von ds10 » 11 Feb 2017, 22:12

Dann lösche die Datei einfach, wenn TV-Browser nicht läuft.

Re: could not store settings for programminfo .....

von renzorosso » 07 Feb 2017, 11:58

Auffällig ist, dass die Datei programinfo.ProgramInfo.prop.temp leer ist, während die Datei java.programinfo.ProgramInfo.prop auf 27,5 MB aufgebläht ist,
Eine alte Sicherungskopie der Datei java.programinfo.ProgramInfo.prop vom 29.06.2016 hat hingegen nur die Größe von 782 KB.
asdfg.JPG
asdfg.JPG (27.12 KiB) 1690 mal betrachtet
Ich habe zuerst mal alle löschbaren Plugins entfernt und den TV-Browser neu gestartet. Hat nichts genutzt.

Re: could not store settings for programminfo .....

von renzorosso » 07 Feb 2017, 03:20

Die Fehlermeldungen werden immer länger :shock:
Could not store settings for programinfo.

----- Start of stacktrace -----
java.io.IOException: Could not store settings to C:\Users\Medion\AppData\Roaming\TV-Browser\3.4.4\programinfo.ProgramInfo.prop.temp
at tvbrowser.extras.common.ConfigurationHandler.storeSettings(ConfigurationHandler.java:169)
at tvbrowser.extras.programinfo.ProgramInfoSettings.storeSettings(ProgramInfoSettings.java:245)
at tvbrowser.extras.programinfo.ProgramInfo.store(ProgramInfo.java:197)
at tvbrowser.TVBrowser.flushSettings(TVBrowser.java:1152)
at tvbrowser.TVBrowser.shutdown(TVBrowser.java:1580)
at tvbrowser.ui.mainframe.MainFrame.quit(MainFrame.java:1574)
at tvbrowser.ui.mainframe.MainFrame.quit(MainFrame.java:1523)
at tvbrowser.ui.mainframe.MainFrame.quit(MainFrame.java:1519)
at tvbrowser.ui.tray.SystemTray$7.windowClosing(SystemTray.java:240)
at java.awt.AWTEventMulticaster.windowClosing(Unknown Source)
at java.awt.AWTEventMulticaster.windowClosing(Unknown Source)
at java.awt.Window.processWindowEvent(Unknown Source)
at javax.swing.JFrame.processWindowEvent(Unknown Source)
at java.awt.Window.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.awt.EventQueue.access$500(Unknown Source)
at java.awt.EventQueue$3.run(Unknown Source)
at java.awt.EventQueue$3.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue$4.run(Unknown Source)
at java.awt.EventQueue$4.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at util.ui.textcomponentpopup.TextComponentPopupEventQueue.dispatchEvent(TextComponentPopupEventQueue.java:55)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)
----- End of stacktrace -----

Re: could not store settings for programminfo .....

von renzorosso » 06 Feb 2017, 22:58

Hallo,
auch ich habe den o.g. Fehler, der nach einem PC-Absturz auftrat.
Could not store settings for programinfo.

----- Start of stacktrace -----
java.io.IOException: Could not store settings to C:\Users\Medion\AppData\Roaming\TV-Browser\3.4.4\programinfo.ProgramInfo.prop.temp
at tvbrowser.extras.common.ConfigurationHandler.storeSettings(ConfigurationHandler.java:169)
at tvbrowser.extras.programinfo.ProgramInfoSettings.storeSettings(ProgramInfoSettings.java:245)
at tvbrowser.extras.programinfo.ProgramInfo.store(ProgramInfo.java:197)
at tvbrowser.TVBrowser.flushSettings(TVBrowser.java:1152)
at tvbrowser.TVBrowser$5.run(TVBrowser.java:879)
----- End of stacktrace -----
Das Mediathek-Plugin habe ich gelöscht, aber der Fehler ist immer noch da. :shock:

Re: could not store settings for programminfo .....

von Jo » 05 Aug 2012, 18:48

Kann ja nicht schaden, wenn man es weiß. Aber ob man mit dem Wissen dann was machen kann, das weiß ich nicht.

Re: could not store settings for programminfo .....

von private_lock » 05 Aug 2012, 01:46

Die Beta läuft mit dem alten Mediathek Plugin was diesen Bug angeht stabil.

Interessiert sich überhaupt noch jemand für diesen Bug, oder soll ich einfach meine Mediathek selbst aktualisieren. Irgendwie hab ich das Gefühl, dass der Bug dann von allein verschwindet. Oder möchte noch jemand im Detail herausfinden, warum das neue Plugin auf der alten Verzeichnisstruktur zu viele Dateien öffnet?

Re: could not store settings for programminfo .....

von private_lock » 02 Aug 2012, 20:47

OK, bin jetzt zuversichtlich, dass mein produktives Profil mit dem Downgrade der Mediathek wieder stabil läuft.

Probiere jetzt das Upgrade auf die neuste TVB-Beta und schau mal, ob damit das Mediathek-Plugin auch rumzickt. (Hab die ganze Zeit über nicht mehr die Mediathek selbst gestartet)

Re: could not store settings for programminfo .....

von private_lock » 31 Jul 2012, 00:37

Mediathek 2.8.5.0 beta (Installierte Version: 2.8.0.1 beta)

Das muss der Schuldige sein. Heute morgen habe ich wieder mit einer frischen Kopie meines Backups angefangen und nur dieses eine Update eingespielt. Den Tag über war es ruhig bis heute Abend die TV-Daten aktualisiert wurden. Diesmal auch ohne Erinnerung kam kurz später der übliche Dreiklang von Exceptions.

Ich habe TVB beendet und neu gestartet. Sofort lief ein erneuter Abgleich der TV-Daten an (scheint, als hätte die vorige Instanz nicht mehr schreiben können, dass sie bereits aktualisiert hatte?) Im Anschluss an die "Verarbeitung" kehrt die GUI normal zur Tagesordnung zurück. Man kann auch Sachen anklicken. Allerdings läuft der Java-Prozess noch ca. 10 Minuten weiter und beansprucht einen kompletten Kern für sich. Danach habe ich versucht, die Liste der zu aktualisierenden Plugins einzusehen. Das wird aber verweigert mit dem Hinweis, dass ja keine Internetverbindung verfügbar sei. Und seither geht es alle 5 Minuten weiter mit dem üblichen Exception-Dreiklang.

Als nächsten Schritt werde ich jetzt gezielt das Mediathek-Plugin downgraden in meinem produktiven Profil und sehen, ob ich damit die Exception weg bekomme.

Ach so noch eine Anmerkung am Rande: Ich habe die Mediathek selbst schon eine ganze Weile nicht mehr gestartet. Vielleicht hat sich dort die Datei/Verzeichnisstruktur geändert? Somit versucht das neue Plugin evtl. auf Dateien zuzugreifen, die es (noch) nicht gibt in meinem veralteten Datenstand?

Re: could not store settings for programminfo .....

von private_lock » 30 Jul 2012, 01:22

Ja, Jo, die Nachricht hatte sich schon zu mir rumgesprochen, danke. Ich wollte nur erst noch diesen Bug festnageln.

Fortschritte: Eines der beiden Plugins muss Schuld sein:

Mediathek 2.8.5.0 beta (Installierte Version: 2.8.0.1 beta)
Videotext 2.7.0.17 (Installierte Version: 2.7.0.15)

Außerdem ist ein Datenupdate nötig und anschließend bei der ersten Erinnerung tritt der Fehler auf (gibt sofort 3 Exceptions). Und im Anschluss muss ich 28 Fehlermeldungen wegklicken, bis TVB endlich aufgibt und sich beendet.

Sobald ich mir mit einem sicher der beiden bin, kann ich es auch mit der aktuellen TVB Beta probieren.

Re: could not store settings for programminfo .....

von Jo » 29 Jul 2012, 10:32

private_lock hat geschrieben:PS: TVB Version 3.1.0.50 SVN hier aus dem Forum
Die derzeit neueste Version ist 3.2beta1 unter http://hilfe.tvbrowser.org/viewtopic.php?f=2&t=15402

Re: could not store settings for programminfo .....

von private_lock » 29 Jul 2012, 10:14

Kleine Wasserstandsmeldung

Datenübersicht 1.2.0.0 beta (installierte Version: 1.1.0.1)
Internet-Suche 3.0.3.0 (installierte Version: 3.0.2.0)
Laufende Sendungen 3.2.0.0 beta (Installierte Version: 3.0.2.0)

sind vorerst entlastet -> bislang kein Fehler.

Teste jetzt die nächsten ...

PS: TVB Version 3.1.0.50 SVN hier aus dem Forum

Re: could not store settings for programminfo .....

von ds10 » 28 Jul 2012, 09:42

Ein Downgrade im selben Profil ist nur dann möglich, wenn sich an der Datenversion des Plugins nichts geändert hat. Das musst du dann ausprobieren. Hast du TV-Browser schon in der neuen Beta-Version?

Re: could not store settings for programminfo .....

von private_lock » 28 Jul 2012, 08:56

Danke erst mal für die Info.

Zunächst kommt zu den Symptomen noch hinzu, dass ich auch einmal die Meldung bekam, dass für den aktuellen Tag gar keine Daten vorhanden seien und erst wieder neu heruntergeladen werden mussten.

Außerdem muss ich dazu sagen, dass ich jetzt einige Male den Java-Prozess abgeschossen habe, weil es beim Beenden zu nervig ist, die ca. 20 Fehlermeldungen (eine pro Plugin?) wegzuklicken.

Dafür habe ich es jetzt schon mal eingegrenzt:

Das aktuelle Profil habe ich umbenannt. Dadurch fiel TVB zurück auf ein älteres Profil vom Dezember 2011. Im ersten Versuch habe ich ihn die Plugins aktualisieren lassen und bekam relativ schnell den Fehler. (Known BAD)

Ausschließen kann ich bereits SpringeZuSendung 0.0.5.0 (Fehler tritt auch ohne dieses Plugin auf, weil es gar nicht in dem alten Backup drin war)

2. Versuch, ich hab die neu erstellte Kopie des alten Profils mit den aktualisierten Plugins noch mal weggelöscht und laufe derzeit stabil, d.h. ohne Fehler auf einer frischen Kopie des Backup ... jedenfalls soweit man die Abwesenheit eines Fehlers überhaupt annehmen kann. (Known GOOD)

Folgende Plugins werden mir zum Update angeboten (waren veraltet in dem Profil schon drin):
  1. Datenübersicht 1.2.0.0 beta (installierte Version: 1.1.0.1)
  2. Internet-Suche 3.0.3.0 (installierte Version: 3.0.2.0)
  3. Laufende Sendungen 3.2.0.0 beta (Installierte Version: 3.0.2.0)
  4. Mediathek 2.8.5.0 beta (Installierte Version: 2.8.0.1 beta)
  5. Videotext 2.7.0.17 (Installierte Version: 2.7.0.15)
  6. WirSchauen 0.2.1.0 (Installierte Version: 0.2.0.2)
Frage an die anderen Betroffenen: Welche Versionen dieser 6 Plugins habt Ihr installiert?
Ich werde jetzt die Hälfte updaten und sehen, ab wann der Fehler auftritt. Dauert halt immer etwas, bis ich sicher sein kann, falls er nicht auftritt.

Frage an ds10: Kann ich die Plugins in meinem produktiven Profil downgraden, indem ich einfach das entsprechende jar vom Backup ersetze oder gibt es noch irgendwelche abhängige Dateien, wo es sich registriert? Was ist mit Daten, die das Plugin selbst speichert? Dank des Fehlers dürfte eigentlich nicht viel gespeichert worden sein ...

Dann bis später
private_lock

Re: could not store settings for programminfo .....

von ds10 » 27 Jul 2012, 00:14

Ausgegraute Plugins können nicht deaktiviert werden. Lieblingssendungen, Erinnerungen, Programinfo und Suche können auch nicht deinstalliert werden, da sie Teil von TV-Browser selbst sind.

Alle anderen Plugins lassen sich durch löschen der Plugindatei entfernen, liegen diese im Plugin-Verzeichnis des Benutzers lassen sie sich direkt aus TV-Browser löschen. Im Systemverzeichnis muss der Admin die Löschung manuell vornehmen, da liegt seit 3.0.2 aber nur noch das News-Plugin.

Nach oben