Task wird erstellt, aber funktioniert nicht

Antwort erstellen


Diese Frage dient dazu, das automatisierte Versenden von Formularen durch Spam-Bots zu verhindern.

BBCode ist eingeschaltet
[img] ist eingeschaltet
[flash] ist ausgeschaltet
[url] ist eingeschaltet
Smilies sind ausgeschaltet

Die letzten Beiträge des Themas

Ich habe die Datenschutzerklärung gelesen und bin damit einverstanden.

   

Ansicht erweitern Die letzten Beiträge des Themas: Task wird erstellt, aber funktioniert nicht

Re: Task wird erstellt, aber funktioniert nicht

von dikig » 25 Feb 2019, 19:32

Danke ds10. Das Problem ist gelöst. Nachdem ich Java in einen Pfad ohne Leerzeichen installiert habe, startete die WinTVCap_GUI Task anstandslos.
Bisher hatte ich das nicht in Betracht gezogen, zumal es auf dem anderen PC im Standardpfad (mit Leerzeichen) anstandslos funktioniert.

Nun, man muss nicht alles verstehen :D

Vielen Dank für Deine schnelle Hilfe
Dikig

Re: Task wird erstellt, aber funktioniert nicht

von ds10 » 25 Feb 2019, 10:22

Es ist möglich den Pfad von Java bei der Installation von Java zu ändern. Ohne Leerzeichen sollte es auf jeden Fall funktionieren.

Task wird erstellt, aber funktioniert nicht

von dikig » 24 Feb 2019, 19:21

Ich benutze seit einiger Zeit den TV-Browser auf einer Win7 (32Bit) Maschine und nehme via VLC gelegentlich Sendungen auf. Das funktioniert recht zuverlässig. Nun wollte ich auf meinem Win7 (64bit) Laptop ebenfalls Video-Aufnahmen machen können und bis auf eine 'Kleinigkeit' funktioniert alles, wie es soll: TV-Browser, Task erstellen mit WinTVCap_GUI-Scheduler2, WinTVCap_GUI (nur Direktaufnahmen) und last not least das aktuelle VLC (nur die portable Version).
Was nicht funktioniert ist die Task selbst. Ich kann sie zwar im Aufgabenplaner sehen, doch auch bei einem manuellen Start aus dem Aufgabenplaner läuft nichts. Nachdem ich die Task exportiert und analysiert habe ist mir aufgefallen, dass der Start von Java ohne Anführungszeichen ein Problem mit dem Leerzeichen im Pfad hat: 'C:\Program Files\Java\jre1.8.0_171\bin\javaw.exe'. Wenn ich den Command String mit den entsprechenden Argumenten aus einem DOS Fenster verschicke, funktioniert der Start von Java jedoch wie erwartet, nur mit den Anführungszeichen und die Aufnahme wird gestartet. Warum das aber bei der anderen Maschine mit dem 32Bit Windows läuft, kann ich mir nicht erklären.
Java ist bei mir im Standardpfad installiert und bisher habe ich noch nicht versucht, Java in einen anderen Verzeichnispfad ohne Leerzeichen zu installieren. Keine Ahnung, ob das geht.

Nun frage ich mich, ob es eine Lösung für dieses Problem gibt?

Vielen Dank
Dikig

Nach oben