[Debian] TV-Browser 4.0.1 startet nicht mehr

Fehler in TV-Browser
Antworten
Octane
Newbie
Beiträge: 3
Registriert: 01 Apr 2018, 08:11

[Debian] TV-Browser 4.0.1 startet nicht mehr

Beitrag von Octane » 01 Apr 2018, 09:09

Programm-Version: 4.0.1
Sowohl stable/final als auch die nightlies, bis 31.03. Ob installiert via .deb oder als Portable macht keinen Unterschied. Mit altem oder komplett frischem Profil das selbe Fehlerbild.

OS: Debian Testing (buster/sid)
Kernel: Linux 4.15.0-2-amd64 #1 SMP Debian 4.15.11-1 (2018-03-20) x86_64 GNU/Linux


Java-Version: 9.0.4

Konsolenausgabe:

Code: Alles auswählen

./tvbrowser-transportable.sh
Starting TV-Browser...
Java exec found in PATH. Verifying...
Suitable java version found [java = 9.0.4]
Configuring environment...
Loading TV-Browser:
java -Xms16m -Xmx512m -XX:+IgnoreUnrecognizedVMOptions --add-modules=ALL-SYSTEM -Djava.library.path="/home/octane/Portable/tvbrowser-transportable" -Dpropertiesfile=linux.properties -jar tvbrowser.jar ''
WARNING: Using incubator modules: jdk.incubator.httpclient
Fehler: Hauptklasse tvbrowser.TVBrowser kann nicht initialisiert werden
Ursache: java.lang.ClassFormatError: Incompatible magic value 2327595568 in class file java/awt/Component
TV-Browser TERMINATED.
Hat jemand von euch eine Idee, wie man diesen Fehler möglicherweise beheben könnte? Danke schon mal für eure Antworten!

Beste Grüße,
Octane

ds10
Site Admin
Beiträge: 16558
Registriert: 23 Jun 2005, 12:36
Kontaktdaten:

Re: [Debian] TV-Browser 4.0.1 startet nicht mehr

Beitrag von ds10 » 01 Apr 2018, 12:15

Verwende Java 8.
"First they ignore you, then they ridicule you, then they fight you, then you win." - Mahatma Gandhi
Unterstütze die Weiterentwicklung von TV-Browser

Octane
Newbie
Beiträge: 3
Registriert: 01 Apr 2018, 08:11

Re: [Debian] TV-Browser 4.0.1 startet nicht mehr

Beitrag von Octane » 01 Apr 2018, 13:15

ds10 hat geschrieben:Verwende Java 8.
Also ist dies hier offensichtlich nicht zutreffend:
TV-Browser 4.0.1 bringt außerdem noch die grundsätzliche Unterstützung für Java 9 mit, das bedeutet, dass TV-Browser nun auch mit Java 9 gestartet werden kann.

Benutzeravatar
Siggi
Moderator
Beiträge: 2096
Registriert: 31 Dez 2003, 12:21
Wohnort: Doberlug - Kirchhain

Re: [Debian] TV-Browser 4.0.1 startet nicht mehr

Beitrag von Siggi » 01 Apr 2018, 13:17

Wenn der Entwickler schreibt, dass du die Version 8 nehemen sollst, wird das wohl stimmen.

Die Unterstützung für Version 9 ist generell implementiert, funktioniert halt noch nicht überall.
Grundsätzlich liegt das auch an der sehr weitreichenden Änderung in Java 9.
mfg Siggi

PS: Wer Fehler findet, darf Sie behalten!!! :-)

Octane
Newbie
Beiträge: 3
Registriert: 01 Apr 2018, 08:11

Re: [Debian] TV-Browser 4.0.1 startet nicht mehr

Beitrag von Octane » 01 Apr 2018, 13:23

Okay, dann werde ich das entsprechend tun, kein Problem. Allerdings finde ich die o.g. Aussage dann doch etwas irreführend.

Grüße
Octane

ds10
Site Admin
Beiträge: 16558
Registriert: 23 Jun 2005, 12:36
Kontaktdaten:

Re: [Debian] TV-Browser 4.0.1 startet nicht mehr

Beitrag von ds10 » 08 Apr 2018, 22:15

Man muss das "grundsätzlich" in der News beachten, d.h. dass es nicht immer funktionieren muss. Insbesondere da der Augenmerk bei der Java-9-Unterstützung bei Windows lag.
"First they ignore you, then they ridicule you, then they fight you, then you win." - Mahatma Gandhi
Unterstütze die Weiterentwicklung von TV-Browser

Antworten