Kann Java Laufzeitumgebung nicht laden

Bei Problemen mit der Bedienung von TV-Browser, bitte hier posten.
Antworten
frank_gayer
Junior Member
Beiträge: 37
Registriert: 24 Jul 2004, 00:52
Kontaktdaten:

Kann Java Laufzeitumgebung nicht laden

Beitrag von frank_gayer »

Hallo,

ich bin seit dieser Woche auf Mac OS 10.10. und kann TV-Browser nicht mehr starten. Ich bekomme die Fehlermeldung dass die Java Laufzeitumgebung nicht gestartet werden kann. Gibt es dafür einen Fix ?
Frank
--------------------------

Infos rund um die USA und vieles mehr unter www.frankgayer.com

ds10
Site Admin
Beiträge: 17625
Registriert: 23 Jun 2005, 12:36
Kontaktdaten:

Re: Kann Java Laufzeitumgebung nicht laden

Beitrag von ds10 »

Aktuellen Release-Kandidaten testen:
http://hilfe.tvbrowser.org/viewtopic.php?f=2&t=16993
"First they ignore you, then they ridicule you, then they fight you, then you win." - Mahatma Gandhi
Unterstütze die Weiterentwicklung von TV-Browser

tatze
Full Member
Beiträge: 84
Registriert: 06 Dez 2004, 14:28
Wohnort: zu Hause

Re: Kann Java Laufzeitumgebung nicht laden

Beitrag von tatze »

Heute 3.4.1 runtergeladen: jetzt habe ich die Fehlermeldung des Betreffs (»Kann die Java Laufzeitumgebung nicht laden.«)

3.4 läuft und liefert diese Informationen:
Version: 3.4
Plattform: Mac OS X 10.10.1
System: x86_64
Java-Version: 1.6.0_65
Java HotSpot(TM) 64-Bit Server VM Apple Inc. /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home

Jemand eine Idee, was das Problem ist?
Vielen , vielen Dank!

ds10
Site Admin
Beiträge: 17625
Registriert: 23 Jun 2005, 12:36
Kontaktdaten:

Re: Kann Java Laufzeitumgebung nicht laden

Beitrag von ds10 »

Oracle Java 7 installieren.
"First they ignore you, then they ridicule you, then they fight you, then you win." - Mahatma Gandhi
Unterstütze die Weiterentwicklung von TV-Browser

tatze
Full Member
Beiträge: 84
Registriert: 06 Dez 2004, 14:28
Wohnort: zu Hause

Re: Kann Java Laufzeitumgebung nicht laden

Beitrag von tatze »

Danke vielmals! Das hat geholfen.
Merkwürdig, denn mein Java steht auf "automatische Update-Überprüfung".

Wäre es technisch möglich, dass TV-Browser beim Start statt "kann Laufzeitumgebung nicht laden" eine informativere Nachricht ausgibt?
Zum Beispiel "TV-Browser benötigt eine neuere Java-Version".

ds10
Site Admin
Beiträge: 17625
Registriert: 23 Jun 2005, 12:36
Kontaktdaten:

Re: Kann Java Laufzeitumgebung nicht laden

Beitrag von ds10 »

tatze hat geschrieben:Merkwürdig, denn mein Java steht auf "automatische Update-Überprüfung".
Das bringt in dem Fall aber nichts, weil Apple Java nur bis zur Version 6 bereitstellt. Ab Version 7 wird das Java für OS X von Oracle angeboten und OS X wird keinen Update-Hinweis von Java 6 auf Java 7 anzeigen.
tatze hat geschrieben:Wäre es technisch möglich, dass TV-Browser beim Start statt "kann Laufzeitumgebung nicht laden" eine informativere Nachricht ausgibt?
Zum Beispiel "TV-Browser benötigt eine neuere Java-Version".
Die Meldung stammt nicht von TV-Browser, sondern von dem Programm, was TV-Browser startet.
"First they ignore you, then they ridicule you, then they fight you, then you win." - Mahatma Gandhi
Unterstütze die Weiterentwicklung von TV-Browser

Regengott
Newbie
Beiträge: 2
Registriert: 04 Jan 2015, 16:51

Re: Kann Java Laufzeitumgebung nicht laden

Beitrag von Regengott »

Hi
Ich hätte noch einen Workaround für das geschilderte Java-Problem unter Yosemite: statt der Mac-DMG die portable Version herunterladen, entpacken und manuell starten mit "java -jar tvbrowser.jar".
Der Launcher in der OSX-Variante scheint nicht sauber mit der Apple-JRE zu funktionieren.

Antworten