Ich bringe das Ding nicht zum Laufen.

Bei Problemen mit der Bedienung von TV-Browser, bitte hier posten.
Antworten
Donald-Duck
Junior Member
Beiträge: 35
Registriert: 01 Feb 2018, 14:35

Ich bringe das Ding nicht zum Laufen.

Beitrag von Donald-Duck » 12 Sep 2019, 18:33

Hallo

Ich musste mein Kubuntu 18.04 neu installieren und bin gemäss einer Anleitung im Forum vorgegangen und habe zunächst

Code: Alles auswählen

openjdk-8-jre
installiert. Anschliessend habe ich die heruntergeladene Datei

Code: Alles auswählen

tvbrowser_4.0.1-1_all.deb
installiert, Das hat funktinoniert, ich kann den TV-Browser in den Listen erkennen. Wenn ich dasnn starte erscheint das Startlogo und innert etwa 10 Sekungen ist alles vorbei. Nichts startet.

Kann mir jemand bitte helfen?

ds10
Site Admin
Beiträge: 17326
Registriert: 23 Jun 2005, 12:36
Kontaktdaten:

Re: Ich bringe das Ding nicht zum Laufen.

Beitrag von ds10 » 12 Sep 2019, 20:00

Das Installieren von Java 8 reicht oft nicht aus, es muss auch das vom System verwendete Java sein. In einer Konsole kann man das einstellen mit:

Code: Alles auswählen

sudo update-alternatives --config java
"First they ignore you, then they ridicule you, then they fight you, then you win." - Mahatma Gandhi
Unterstütze die Weiterentwicklung von TV-Browser

Donald-Duck
Junior Member
Beiträge: 35
Registriert: 01 Feb 2018, 14:35

Re: Ich bringe das Ding nicht zum Laufen.

Beitrag von Donald-Duck » 13 Sep 2019, 00:08

Vielen dank fpr deinen Rat. Das habe ich gemacht und die 2 augewählt.

Nun bekam ich das folgende Resultat:

Code: Alles auswählen

arran@arran:~$ sudo update-alternatives --config java
[sudo] password for arran: 
There are 2 choices for the alternative java (providing /usr/bin/java).

  Selection    Path                                            Priority   Status
------------------------------------------------------------
* 0            /usr/lib/jvm/java-11-openjdk-amd64/bin/java      1111      auto mode
  1            /usr/lib/jvm/java-11-openjdk-amd64/bin/java      1111      manual mode
  2            /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java   1081      manual mode

Press <enter> to keep the current choice[*], or type selection number: 2
update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java to provide /usr/bin/java (java) in manual mode
arran@arran:~$
Darf ich auf weiteren Beistand hoffen, denn ich verstehe eigentich null und gar nichts. Mit der Kubuntu 14.04 war die Installation sehr schnell und einfach. Wieso ist sie nun so kompliziert?

ds10
Site Admin
Beiträge: 17326
Registriert: 23 Jun 2005, 12:36
Kontaktdaten:

Re: Ich bringe das Ding nicht zum Laufen.

Beitrag von ds10 » 13 Sep 2019, 00:24

Damit ist Java 8 aktiviert und TV-Browser sollte starten.

Der Unterschied zu 14.04 ist, dass Java 11 jetzt der Standard ist und nicht mehr Java 8. Die nächste Version von TV-Browser wird auch Java 11 voraussetzen und mit Java 8 nicht mehr laufen.
"First they ignore you, then they ridicule you, then they fight you, then you win." - Mahatma Gandhi
Unterstütze die Weiterentwicklung von TV-Browser

Donald-Duck
Junior Member
Beiträge: 35
Registriert: 01 Feb 2018, 14:35

Re: Ich bringe das Ding nicht zum Laufen.

Beitrag von Donald-Duck » 13 Sep 2019, 01:07

Vielen Dank.

Funktioniert jetzt. Gehe dann morgen daran, das Ding korrekt einzurichten. Ich nehme an, dass ich aus der 14.04 einiges mit Copy & Paste herübernehmen kann.

ds10
Site Admin
Beiträge: 17326
Registriert: 23 Jun 2005, 12:36
Kontaktdaten:

Re: Ich bringe das Ding nicht zum Laufen.

Beitrag von ds10 » 13 Sep 2019, 12:22

Ja man kann die Einstellungen übernehmen, siehe Backup.
"First they ignore you, then they ridicule you, then they fight you, then you win." - Mahatma Gandhi
Unterstütze die Weiterentwicklung von TV-Browser

Donald-Duck
Junior Member
Beiträge: 35
Registriert: 01 Feb 2018, 14:35

Re: Ich bringe das Ding nicht zum Laufen.

Beitrag von Donald-Duck » 14 Sep 2019, 18:37

Der Unterschied zu 14.04 ist, dass Java 11 jetzt der Standard ist und nicht mehr Java 8. Die nächste Version von TV-Browser wird auch Java 11 voraussetzen und mit Java 8 nicht mehr laufen.

Ist es dann nicht besser gleich von Anfang an Java 8 auszuwählen? Und wenn ja, die «auto mode» oder die «manual mode»?

ds10
Site Admin
Beiträge: 17326
Registriert: 23 Jun 2005, 12:36
Kontaktdaten:

Re: Ich bringe das Ding nicht zum Laufen.

Beitrag von ds10 » 14 Sep 2019, 20:05

Du wählst es ja nicht aus, Java 11 ist der Standard bei neuen Ubuntu-Versionen. Wenn man aber Java 8 nutzen möchte, muss man das installieren und dann als Standard auswählen.
"First they ignore you, then they ridicule you, then they fight you, then you win." - Mahatma Gandhi
Unterstütze die Weiterentwicklung von TV-Browser

Donald-Duck
Junior Member
Beiträge: 35
Registriert: 01 Feb 2018, 14:35

Re: Ich bringe das Ding nicht zum Laufen.

Beitrag von Donald-Duck » 16 Sep 2019, 16:29

Leider hat das nicht geklappt. Was ich gemacht habe:

Von der 14.04 die gesamte Datei .tvbrowser auf einen leeren USB-Stick kopiert. Es handelt sich um die Version 3.4.4

Auf der 18.04 die Datei .tvbrowser vollständig gelöscht. Version 4.??

Die Datei von der version 14.04 ins /home kopiert.

Computer geschlossen und wieder aufgestartet.

Resultat eine Falschmeldung:
Unable to run the command specified. The file or folder /usr/share/applications/tvbrowser.desktop does not exist.
Was nun?

ds10
Site Admin
Beiträge: 17326
Registriert: 23 Jun 2005, 12:36
Kontaktdaten:

Re: Ich bringe das Ding nicht zum Laufen.

Beitrag von ds10 » 16 Sep 2019, 17:25

Der Fehlermeldung nach zu urteilen, ist TV-Browser nicht installiert.
"First they ignore you, then they ridicule you, then they fight you, then you win." - Mahatma Gandhi
Unterstütze die Weiterentwicklung von TV-Browser

Donald-Duck
Junior Member
Beiträge: 35
Registriert: 01 Feb 2018, 14:35

Re: Ich bringe das Ding nicht zum Laufen.

Beitrag von Donald-Duck » 25 Sep 2019, 14:18

Danke, ich habe es soeben geschafft.

Antworten