Reguläre Ausdrücke funktionieren nicht (bei mir)

Bei Problemen mit der Bedienung von TV-Browser, bitte hier posten.
Antworten
nooby
Newbie
Beiträge: 3
Registriert: 28 Aug 2021, 11:50

Reguläre Ausdrücke funktionieren nicht (bei mir)

Beitrag von nooby »

Hallo

Mein Problem ist, Sendungen werden per Regulärer Ausdruck (.*) nicht gefunden, obwohl es Treffer geben müßte. Selbst das im Wiki genannte Beispiel "star *trek.*" funktioniert nicht. Ich vermute sehr dass der Fehler bei mir liegen muß. Ich habe echt keine Ahnung woran das liegen könnte. Immerhin habe ich dieses Verhalten auf zwei Rechnern.

Meine Ausstattung:
PC1: Windows 7
Java 8 Build 1.8.0_301-b09
TV-Browser 4.0.1

PC2: Windows 10
Java 11.0.11
TV-Browser 4.2.3

Ich erstelle eine Lieblingssendung "Louis de Funès"
Suchbegriff: Louis de Fun.*
Wo Suchen: überall
Optionen: Suchbegriff ist ein Regulärer Ausdruck
--> keine Treffer

aber

Erstelle ich eine Lieblingssendung "Louis de Funès"
Suchbegriff: Louis de Fun
Wo Suchen: überall
Optionen: Suchbegriff ist ein Stichwort
--> 1 Treffer

Wenn ich das Beispiel aus dem Wiki nehme
Suchbegriff: star *trek.*
Wo Suchen: überall
Optionen: Suchbegriff ist ein Regulärer Ausdruck
--> keine Treffer

aber

Suchbegriff: star trek
Wo Suchen: überall
Optionen: Suchbegriff ist ein Stichwort
--> 54 Treffer

Was mache ich falsch?
Jo
Site Admin
Beiträge: 11341
Registriert: 07 Apr 2006, 23:39

Re: Reguläre Ausdrücke funktionieren nicht (bei mir)

Beitrag von Jo »

Die Suche findet so alles, was mit dem Ausdruck anfängt. "star *trek.*" funktioniert z.B. bei Suche nach Titel. Da du alles willst, wo der Begriff drin vorkommt, muss auch noch am Anfang ein ".*" (also "beliebig viele Zeichen" davor).
nooby
Newbie
Beiträge: 3
Registriert: 28 Aug 2021, 11:50

Re: Reguläre Ausdrücke funktionieren nicht (bei mir)

Beitrag von nooby »

Danke für die Antwort, das funktioniert sogar. Warum ist das im Wiki nicht so angegeben?

Mit einem vorausgesetzten ".*" funktioniert auch ".*Louis de Fun.*s".

Vielen Dank
Zuletzt geändert von nooby am 28 Aug 2021, 21:58, insgesamt 1-mal geändert.
Jo
Site Admin
Beiträge: 11341
Registriert: 07 Apr 2006, 23:39

Re: Reguläre Ausdrücke funktionieren nicht (bei mir)

Beitrag von Jo »

Wenn dein regulärer Ausdruck mit "L" anfängt, werden nur Texte gefunden, die mit "L" anfangen. "Louis de Fun" müsste dann z.B. ganz am Anfang der Beschreibung stehen. Wenn du "Louis de Fun" irgendwo in der Beschreibung oder Schauspieler o.ä. finden willst, musst du ".*Louis de Fun.*" nehmen. Also dahinter und davor können noch beliebig viele Zeichen stehen.
nooby
Newbie
Beiträge: 3
Registriert: 28 Aug 2021, 11:50

Re: Reguläre Ausdrücke funktionieren nicht (bei mir)

Beitrag von nooby »

Super Beschreibung, jetzt hab' ich es verstanden, danke Dir vielmals.
Antworten