Sounderinnerer gibt den falschen Sound wieder

Antworten
Sheldon2012
Plugin-Developer
Beiträge: 1206
Registriert: 25 Dez 2012, 07:35

Sounderinnerer gibt den falschen Sound wieder

Beitrag von Sheldon2012 » 12 Aug 2013, 19:12

Hallo,

ich habe wohl mal wieder eine kleine Besonderheit des Sounderinnerers entdeckt.
Folgendes Verhalten habe ich beobachtete:

Die Lieblingssendung LIEBLINGSSENDUNG wird als solche mit dem Titel LIEBLINGSSENDUNG hinterlegt.
Anschließend wird für diese Sendung ein Sound mit dem Suchtext LIEBLINGSSENDUNG hinterlegt.
Wenn nun die Sendung als LIEBLINGSSENDUNG vom TV-Browser gefunden wird, wird der hinterlegte Sound abgespielt.
Soweit so gut. So soll es ja auch sein.

ABER !!!

Wenn wir jetzt einen Sonderfall haben, in dem z.B. in den Sendungsinformationen nicht LIEBLINGSSENDUNG sondern LIEBLINGSSENDUNG (1)
übermittelt wid - und das kommt vor, dann wird die Lieblingsendung gefunden, weil deren Suche clever genung ist, das zu erkennen.
Aber der Sounderinnerer ist da leider nicht ganz so clever. Der scheint nämlich den Titel der Sendung, also LIEBLINGSSENDUNG (1) übermittelt zu bekommen. Der Suchtext lautet aber LIEBLINGSSENDUNG. Folglich ist die implementierung wohl dann so gemacht, dass,falls er nichts findet, der alphabetisch erste Sound abgespielt wird. Jedenfalls habe ich das so beobachtet. Also spielt der Sounderinnerer in diesem Fall den falschen Sound ab.

Derzeit scheint der übermittelte Titel der Sendung an den Sounderinnerer übergeben zu werden.
Das ist in unserem Fall ein Problem. Wenn der hinterlegte Titel der Lieblingssendung LIEBLINGSSENDUNG (s.o.) übergeben werden würde,
also die Hinterlegung bei der Lieblingssendung selbst, würde dieses Problem nicht mehr auftreten.

Oder gibt es eine Möglichkeit, dieses Problem mittels geeigneter Konfiguration zu lösen?
Dann wäre ich natürlich für einen Hinweis sehr dankbar.

Anmerkung:
Die Hinterlegung des gleichen Sounds mit dem Suchtext LIEBLINGSSENDUNG (1) ist ja wohl keine Opzion.
Das sollte man generisch lösen.

Zugegeben! Es handelt sich um eine Ausnahme. Aber da alle Daten zum Zeitpunkt der Übergabe an den Sounderinnerer vorliegen,
sollte das doch machbar sein. Und der TV-Browser wäre wieder ein bischen schöner! :D

Gruß + Bazinga!

Sheldon

ds10
Site Admin
Beiträge: 17164
Registriert: 23 Jun 2005, 12:36
Kontaktdaten:

Re: Sounderinnerer gibt den falschen Sound wieder

Beitrag von ds10 » 12 Aug 2013, 19:47

Dafür gibt es ja den * für den Suchbegriff im Sounderinnerer.
"First they ignore you, then they ridicule you, then they fight you, then you win." - Mahatma Gandhi
Unterstütze die Weiterentwicklung von TV-Browser

Gast

Re: Sounderinnerer gibt den falschen Sound wieder

Beitrag von Gast » 12 Aug 2013, 20:03

Also versteht die Suche im Sounderinnrer eine Wildcard.
Die Lösung in meinem Beispiel wäre also LIEBLINGSSENDUNG* im Suchtext, richtiig?

ds10
Site Admin
Beiträge: 17164
Registriert: 23 Jun 2005, 12:36
Kontaktdaten:

Re: Sounderinnerer gibt den falschen Sound wieder

Beitrag von ds10 » 12 Aug 2013, 20:06

Ja, steht aber auch so unter der Liste der Titel im Bearbeiten-Fenster des Sounderinneres, dort kannst du auch eine Audiodatei angeben, die abgespielt wird, wenn keine Datei für den Titel gefunden wurde.
"First they ignore you, then they ridicule you, then they fight you, then you win." - Mahatma Gandhi
Unterstütze die Weiterentwicklung von TV-Browser

Sheldon2012
Plugin-Developer
Beiträge: 1206
Registriert: 25 Dez 2012, 07:35

Re: Sounderinnerer gibt den falschen Sound wieder

Beitrag von Sheldon2012 » 12 Aug 2013, 20:14

Sorry, ich war wohl gerade nicht mehr eingeloogt.

Aber die Standard-Datei löst ja das Problem nicht.
ich habe jetzt den Suchtext im Sounderinnerer angepasst.
Mal sehen was beim nächsten Aufruf der Sendung passiert.
Aber Du sagst ja, das die Suche den * versteht. Dann sollte es ja klappen.
Falls nicht melde ich mich noch mal.

Da fällt mir auf, dass man das nicht wirklich testen kann.
Hierzu müsste man den Erinnerer aus der Lieblingssendung heraus aufrufen können.
Oder gibt es einen anderen Weg?

Vielen Dank für die Hilfe!

ds10
Site Admin
Beiträge: 17164
Registriert: 23 Jun 2005, 12:36
Kontaktdaten:

Re: Sounderinnerer gibt den falschen Sound wieder

Beitrag von ds10 » 12 Aug 2013, 20:31

Eine Standarddatei löst insofern das Problem, dass du hörst, wenn ein Titel nicht erkannt wurde und dann entsprechend nachsehen könntest.

Natürlich kannst du auch testen, z.B. die Baumansicht öffnen, die Lieblingssendung auswählen, Rechtsklick, Exportieren->Sound-Erinnerer
"First they ignore you, then they ridicule you, then they fight you, then you win." - Mahatma Gandhi
Unterstütze die Weiterentwicklung von TV-Browser

Sheldon2012
Plugin-Developer
Beiträge: 1206
Registriert: 25 Dez 2012, 07:35

Re: Sounderinnerer gibt den falschen Sound wieder

Beitrag von Sheldon2012 » 12 Aug 2013, 20:38

Das wusste ich nicht! Danke, der Test hat geklappt!
Das mit der Standarddatei ist eine gute Idee.
Super !!! Vielen Dank!

Sheldon2012
Plugin-Developer
Beiträge: 1206
Registriert: 25 Dez 2012, 07:35

Re: Sounderinnerer gibt den falschen Sound wieder

Beitrag von Sheldon2012 » 19 Aug 2013, 18:21

Hallo,

ich nehme den Thread noch einmal auf. Alles läuft soweit prima.
Aber nachdem ich alles wie besprochen eingerichtet hatte, ist mir noch eine Kleinigkeit aufgefallen.

Also ich habe einen Standard-Sound hinterlegt, der dann abgespeilt werden soll, wenn für eine Lieblingssendung noch kein spezieller Sound definiert wurde.
Wenn ich nun eine neue Lieblingssendung definiere, wird nach neuen Sendeterminen gesuscht und falls welche gefunden werden, wird dieser Standard-Sound abgespielt. Einen speziellen Sound gibt es ja in unserem Szenario noch nicht. Bis dahin ist alles bestens.

Nun gibt es aus der Liste der Lieblingssendungen im Tab Lieblingssendungen und aus der Baumansicht der Lieblingssendungen im Tab Baumansicht
jeweils die Möglichkeit, eine Folge der jeweiligen Lieblingssendung an den Sounderinnerer zu übergeben. Das war ja unser Soundtest.
Wenn ich das jeweils für eine einzelne Folge mache, wird, wie in unserem Beispiel für eine neue Sendung geplant, der Standard-Sound abgespielt.
Auch gut.

Aber es gibt sowohl im Tab Lieblingssendungen als auch im Tab Baumansicht auch die Möglichkeit, die gesamte Lieblingsendung, also nicht nur eine Folge,
an den Sounderinnerer weier zu geben. Da habe ich einfach mal meinem Spielktrieb nachgegeben und es ausprobiert.

Und hier geschieht nun folgendes:
Liegt für die Lieblingssendung zu dem Zeitpunkt nur eine Folge vor, wird der Standard-Sound abgespielt, wenn kein spezieller hinterlegt ist.
Liegen aber mehrere Folgen vor, so wird zuerst der Standard-Sound und anschließend der erste Sound in der Liste abgespielt.
Zum Vergleich:
Wenn bereitzs ein spezieller Sound hinterlegt ist, wird immer dieser abgespielt. Das funktionier also.

Das ist natürlich kein Drama. Wahrscheinlich hat das noch keiner ausprobiert. Aber das scheint ein kleiner Bug zu sein, oder?

Gruß + Bazinga!

Sheldon

ds10
Site Admin
Beiträge: 17164
Registriert: 23 Jun 2005, 12:36
Kontaktdaten:

Re: Sounderinnerer gibt den falschen Sound wieder

Beitrag von ds10 » 19 Aug 2013, 21:13

Ja, war ein Bug, ist mit Version 0.1.1.1 behoben.
"First they ignore you, then they ridicule you, then they fight you, then you win." - Mahatma Gandhi
Unterstütze die Weiterentwicklung von TV-Browser

Sheldon2012
Plugin-Developer
Beiträge: 1206
Registriert: 25 Dez 2012, 07:35

Re: Sounderinnerer gibt den falschen Sound wieder

Beitrag von Sheldon2012 » 19 Aug 2013, 21:37

Schön, dass der Sound-Erinnerer so wieder ein bischen besser wird.
Kannst Du schon sagen, wann die neue Version verfügbar sein wird?

ds10
Site Admin
Beiträge: 17164
Registriert: 23 Jun 2005, 12:36
Kontaktdaten:

Re: Sounderinnerer gibt den falschen Sound wieder

Beitrag von ds10 » 19 Aug 2013, 21:47

Die ist bereits verfügbar.

[ Post made via Android ] Bild
"First they ignore you, then they ridicule you, then they fight you, then you win." - Mahatma Gandhi
Unterstütze die Weiterentwicklung von TV-Browser

Sheldon2012
Plugin-Developer
Beiträge: 1206
Registriert: 25 Dez 2012, 07:35

Re: Sounderinnerer gibt den falschen Sound wieder

Beitrag von Sheldon2012 » 19 Aug 2013, 22:06

Getestet und für gut befunden! Super! Danke! :D

Antworten