Internet-Suche (String nicht mehr funktionierend)

Antworten
Kanitfastan
Senior Member
Beiträge: 162
Registriert: 20 Jun 2009, 20:29
Wohnort: Salzburg
Kontaktdaten:

Internet-Suche (String nicht mehr funktionierend)

Beitrag von Kanitfastan » 26 Jun 2013, 12:54

Hallo zusammen und danke für diese feine SW. (Wiedermal)

Ich habe jetzt länger die Internet-Suche nicht benützt.
Heute habe ich den String
http://www.zweitausendeins.de/filmlexik ... eNach=alle
erneut versucht und im Gegensatz zu allen anderen Suchen geht dieser nicht mehr.

Ich komme damit leider nicht weiter. Kann mir jemand helfen?

ds10
Site Admin
Beiträge: 17327
Registriert: 23 Jun 2005, 12:36
Kontaktdaten:

Re: Internet-Suche (String nicht mehr funktionierend)

Beitrag von ds10 » 26 Jun 2013, 13:13

Die Seite sieht doch wie ein Onlineshop aus. Falls die vorher mal was anderes unter der Adresse hatten ist das jetzt wahrscheinlich einfach nicht mehr da. Wenn du dort trotzdem suchen möchtest gib doch einfach mal ein Suchbegriff in deren Suchmaske ein und überprüfe dann die URL-Leiste deines Browsers, wie die Anfrage aussieht. Die kannst du dann nutzen um die Einstellungen in TV-Browser zu ändern.
"First they ignore you, then they ridicule you, then they fight you, then you win." - Mahatma Gandhi
Unterstütze die Weiterentwicklung von TV-Browser

Kanitfastan
Senior Member
Beiträge: 162
Registriert: 20 Jun 2009, 20:29
Wohnort: Salzburg
Kontaktdaten:

Re: Internet-Suche (String nicht mehr funktionierend)

Beitrag von Kanitfastan » 26 Jun 2013, 14:48

Ja, die haben einen OL-Shop, das ist die oberer Suchleiste. Der Link geht aber zum "Filmlexikon", was auch dort steht, darunter ist das Suchfeld für Filmkritiken. Das Zweitausendeins Filmlexikon ist die größte Film-DB der Welt. Und bisher habe ich die Suche nach Filmtiteln (es sind Kritiken (u. a.), die man als Ergebnis erhält, z. B.; Der letzte schöne Tag, ARD 20:15) sehr geschätzt.
Deren Kritiken werden übrigens auch gelegentlich in Cinema o. a. zitiert bzw. abgeschrieben.

Wenn man viele Kritiken aufruft, ist es wesentlich schneller, diese feine Funktion vom TVB zu verwenden. Meist schaue ich mehrere, vor allem Zweitausendeins und Cinema aber auch andere an, bevor ich einen Film programmiere. Da war ich bisher froh, dass mir jemand hier vor etwa zwei Jahren beim Erstellen dieser Zweitausendeins-Suche nach dem Muster der anderen Internet-Suchen geholfen hat.

Deinen Tipp:
"Wenn du dort trotzdem suchen möchtest gib doch einfach mal ein Suchbegriff in deren Suchmaske ein und überprüfe dann die URL-Leiste deines Browsers, wie die Anfrage aussieht. Die kannst du dann nutzen um die Einstellungen in TV-Browser zu ändern."
habe ich versucht, die URL-Zeile ist identisch http://www.zweitausendeins.de/filmlexik ... eNach=alle, gebe ich diese dann in ein neues Fenster ein, kommt aber keine Suche, sondern nur das genannte Suchportal. (Die Seite reagiert also genau wie auf die TVB Suche, nämlich gar nicht.
Ich komm allein nicht weiter.

ds10
Site Admin
Beiträge: 17327
Registriert: 23 Jun 2005, 12:36
Kontaktdaten:

Re: Internet-Suche (String nicht mehr funktionierend)

Beitrag von ds10 » 26 Jun 2013, 15:16

Nun nach einer kurzen Einsicht in den Quellcode der Seite hast du da keine Chance mehr. Das Formular wurde auf POST umgestellt, d.h. per URL kann man keine Suchergebnisse mehr erhalten.
"First they ignore you, then they ridicule you, then they fight you, then you win." - Mahatma Gandhi
Unterstütze die Weiterentwicklung von TV-Browser

Kanitfastan
Senior Member
Beiträge: 162
Registriert: 20 Jun 2009, 20:29
Wohnort: Salzburg
Kontaktdaten:

Re: Internet-Suche (String nicht mehr funktionierend)

Beitrag von Kanitfastan » 26 Jun 2013, 15:40

Danke dir für die schnelle Hilfe. Schade, sowas in der Art hab ich schon vermutet, ich war wohl nicht der einzige, der das gerne genutzt hat.

Kanitfastan
Senior Member
Beiträge: 162
Registriert: 20 Jun 2009, 20:29
Wohnort: Salzburg
Kontaktdaten:

Re: Internet-Suche (String nicht mehr funktionierend)

Beitrag von Kanitfastan » 26 Jun 2013, 16:12

Eine Möglich könnte es noch geben:
Opera (den verwende ich meistens) beherrscht das Erstellen einer Suche für diese POST-Eingabe bei Zweitausendeins. Diese Opera Suche könnte ich jetzt aufrufen mit einem Kürzel vor dem Suchinhalt, beispielsweise zzz.
Das ginge aber nur, wenn ich den Backslash einbauen kann:
Bild

Das ist wohl nicht machbar, oder?

ds10
Site Admin
Beiträge: 17327
Registriert: 23 Jun 2005, 12:36
Kontaktdaten:

Re: Internet-Suche (String nicht mehr funktionierend)

Beitrag von ds10 » 26 Jun 2013, 16:20

Die Internetsuche wird doch mit dem Standardbrowser aufgerufen, den Browser kannst du da nicht eingeben. Dafür wäre eher die Aufnahmesteuerung oder das SwitchPlugin geeignet.
"First they ignore you, then they ridicule you, then they fight you, then you win." - Mahatma Gandhi
Unterstütze die Weiterentwicklung von TV-Browser

Kanitfastan
Senior Member
Beiträge: 162
Registriert: 20 Jun 2009, 20:29
Wohnort: Salzburg
Kontaktdaten:

Re: Internet-Suche (String nicht mehr funktionierend)

Beitrag von Kanitfastan » 26 Jun 2013, 18:27

Wie du am gezeigten Ergebnis sehen kannst, ginge es. / Wenn der Backslash übergeben werde könnte. (Natürlich getestet.)

(Ob das dann der Systemstandard-Browser oder ein individuell anderer (hier sind Opera, IE, Firefox und Chrome parallel.) ist, ist egal. In meinem Fall ist der Opera Standard-Vorgabe, öffnet ein neues Fenster und führt die POST-Suche auf der übergebenen Seite aus.)

Selbstverständlich werde ich deine Tipps versuchen.

ds10
Site Admin
Beiträge: 17327
Registriert: 23 Jun 2005, 12:36
Kontaktdaten:

Re: Internet-Suche (String nicht mehr funktionierend)

Beitrag von ds10 » 26 Jun 2013, 18:56

Nein es würde nicht funktionieren, auch nicht mit dem Backslash (um den einzugeben muss man den doppelt hintereinander schreiben, auch ein Slash würde funktionieren, da Windows den auch als Pfadangabe akzeptiert). Da steht URL, da kann man kein Windows-Programm angeben, denn was das Plugin macht ist den Standardbrowser aufzurufen mit der angegebenen URL, was du da also machen würdest ist deinem Standardbrowser zu sagen die in URL eingegebenen Werte aufzurufen, nur der wird die nicht finden, da die hier keine URL sind.

Was du möchtest kannst du aber ganz einfach mit dem SwitchPlugin erreichen indem du dort Opera als auszuführendes Programm angibst. (Das Gleiche ginge auch mit der Aufnahmesteuerung.)
"First they ignore you, then they ridicule you, then they fight you, then you win." - Mahatma Gandhi
Unterstütze die Weiterentwicklung von TV-Browser

Kanitfastan
Senior Member
Beiträge: 162
Registriert: 20 Jun 2009, 20:29
Wohnort: Salzburg
Kontaktdaten:

Re: Internet-Suche (String nicht mehr funktionierend)

Beitrag von Kanitfastan » 26 Jun 2013, 22:15

So ist das eben, man wird blind, wenn man sich in eine Idee verrennt. Dank dir.
Jetzt hab ich meinen Denkfehler erkannt und dich verstanden.

Super, so klappt es, dann nehme ich einfach für diese DB ein anderes Suchicon.

Jo
Site Admin
Beiträge: 10868
Registriert: 07 Apr 2006, 23:39

Re: Internet-Suche (String nicht mehr funktionierend)

Beitrag von Jo » 30 Jun 2013, 21:29

Zur Not ginge auch
http://www.kabeleins.de/film/filmlexiko ... %20Waltons (findet aber gerade da nichts)
http://www.bs-net.de/suche/ergebnis.htm ... ie+Waltons (findet aber gerade da auch nichts)
Bringt also nix, wenn du Waltons-Fan bist, aber sonst vielleicht.

ds10
Site Admin
Beiträge: 17327
Registriert: 23 Jun 2005, 12:36
Kontaktdaten:

Re: Internet-Suche (String nicht mehr funktionierend)

Beitrag von ds10 » 30 Jun 2013, 21:33

Ich nehme mal an Die Waltons stehen da nur, weil das die Beispielsendung von TV-Browser ist, mit der auch alles in den Einstellungen getestet wird.
"First they ignore you, then they ridicule you, then they fight you, then you win." - Mahatma Gandhi
Unterstütze die Weiterentwicklung von TV-Browser

ReiniAugsburg
Newbie
Beiträge: 5
Registriert: 20 Dez 2007, 07:29

Re: Internet-Suche (String nicht mehr funktionierend)

Beitrag von ReiniAugsburg » 01 Jul 2013, 05:11

Was aber immer noch funktioniert, ist der direkte Aufruf eines Filmes mit dessen ID:
http://www.zweitausendeins.de/filmlexik ... 0Elisabeth
bringt kein Ergebnis, während
http://www.zweitausendeins.de/filmlexik ... wert=16228
das korrekte Ergebnis liefert - auch im Firefox und auch mit WGet.
Ob das an der POST-Methode liegt, frag ich mich jetzt schon...

Antworten